Discontinuing Support for Android Lollipop OS (Android 5)

 

Support for GeoPal users on Android devices running Android Lollipop (Android 5) will be discontinued.

Why are we discontinuing support on Lollipop OS?

Google, the company developing the Android Operating System, stopped offering support for Lollipop OS in 2017. This means that there have been no updates for this version of the operating system. Devices on this version will no longer be able to receive the necessary security updates needed to access the GeoPal App and therefore we can no longer support them.

When are we discontinuing it?

We'll stop offering support for devices running on Lollipop OS from 30 April 2020.

What do I need to do?

We advise our Android users running Lollipop to upgrade to a higher Android version, ideally the latest version of the operating system -Android 10. By doing this you'll gain access to all the latest updates and features - giving you the best experience of the GeoPal app!

What is the new minimum supported Android OS?

As of 1 May 2020, the minimum requirement for Android devices supported by the GeoPal app is Android 6.0 Marshmallow. If the devices in use cannot be updated to Android 6 or above, then they should be replaced before 30 April 2020.

Share This